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   Basic Installation Troubleshooting 
 

 

Introduction 

The purpose of this app-note is to guide you through the basic troubleshooting of Copley drives on 

an existing installation. This guide is intended to be used only as a reference. 

Requirements 

Laptop with Windows 7 (64 Bit). 32 Bit can only be used with older drives and CME V7.1 

Laptop with Windows 10 (64 Bit) 

Copley setup software CME V8.1 for 64-bit Windows computer 

Copley setup software Legacy CME V7.1 for 32-bit Windows 

CME\HELP\All documents\CME User Guide  

Copley USB to Serial adapter (Part# SER-USB-RJ11) using Prolific Drivers  

Digital Multi Meter (to measure AC/DC voltage supply, Motor ohms, and cable continuity 
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Troubleshooting Procedures 

Please note that steady or flashing LED lights on Copley drive’s “STATUS LED’s” have a meaning 

which is explained below.   

LED Drive Status and 

Actions 

Condition Action 

No LED No Power Check DC power with DMM 

Red/Blinking Latching fault Check ALL cables, including pins, 

shields, and grounds. Cycle DC 

Power to RESET the drive. For dual-

axis drives, make sure the 

FEEDBACK cables are connected to 

the correct corresponding MOTOR 

connection. 

Red/Solid Transient fault condition If AC powered drive, check AC 

Power. Drive will resume operation 

when the condition causing the 

fault is removed. 

Green/Double-Blinking STO circuit active, drive 

outputs are Safe-Torque-

Off 

Install STO Interlock or STO Jumper 

Green/Slow-Blinking Drive OK but NOT enabled Will run when enabled 

Green/Fast-Blinking Positive or 

Negative limit 

switch active 

Move in direction not inhibited by 

limit switch 

Green/Solid Drive OK and enabled Will run in response to 

reference inputs or EtherCAT 

commands. 

In the rare event that your Copley drive is not working properly, please try the following steps.  

Before troubleshooting make sure that the drive is shut off and no live power is 

connected to the drive.  

1. Make sure the drive is securely installed. 

2. Make sure your 24VDC Power & AC Power (if AC Drive) are securely connected. 

3. Make sure your MOTOR cable(s) are securely connected. 

4. Make sure your FEEDBACK cable(s) and IO cable(s) (if used) are securely connected. 
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5. Make sure your communication to the drive is properly connected; could be serial to USB 

cable (Part# SER-USB-RJ11) or CAN cable and USB adapter (Part# CAN-USB-01). 

6. Make sure the drive frame makes good contact with the metal frame of the machine.  

7. Turn on DC power, then turn on AC power.  

If the Copley drive continues to present a FAULT condition, please open CME and follow the next 

steps to try to isolate the source of the problem. 

Saving Configuration Files 

CME allows you to save to a computer the different data formats utilized by CME. In a 

standard installation, CME will save all files in the following location:  

C:\Users\Public\Public Documents\Copley Motion\CME 

The table below provides the different save options, the format file type, and a brief 

explanation of the function performed: 

Option File 
Type 

Description  

Save Amplifier Data .ccx Saves the parameters of the amplifier RAM to a file on 

disk. 

Save a CVM 

Program 
.ccp Saves the current CVM control program to a file with a 

.ccp filename extension 

Save a Gain 

Schedule 

.ccg The gain Scheduling allows the user to schedule gain 

adjustments based on changes to specific parameters. 

Encoder Correction 

table 
.cce Saves a correction table (encoder correction) from the 

flash to a file with a .cce filename extension 

Save a CAM table .cct Camming is an effective way to produce repetitive motion 
synchronized to an external device. A pre-defined cam-

table of slave positions is typically cycled through by a 
master encoder connected to the drive. The drive 

performs a linear interpolation between points to 

minimize cam-table size. 

Master using FOE 

(File over 

EtherCAT) or FOC 
(File over 

CANopen) 

.ccd A .ccd file contains all the driver files and 

EEPROM/FLASH. 
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Example: To save a .ccx file please follow the steps below: 

1. Go to File → Save Amplifier Data (.ccx). 

 

2. The window below will display. 

 

In the image above, the file “XEC_ParkerCBL” will be saved in the file AmpData:  

C:\Users\Public\Documents\Copley Motion\CME 2\AmpData 

3. Click the Save button to save the file. 
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Viewing the Error Log 

The image below shows a screen capture of the Error Log window.  The following table 

provides a brief description of the different tabs and functions of the Error Log window. 

 

Tab Contents  

Active Type and description of each active fault and warning. The contents of this 

tab are automatically refreshed as new events occur. 

History Type, description, and time of occurrence of each fault and warning since the 

log was last cleared. The contents of this tab are not refreshed automatically 
as new events occur. The contents are refreshed only when the tab is 

displayed or when Refresh is clicked. 

Frequency Type, description, and frequency of each fault and warning that has occurred 
since the log was last cleared. The contents are refreshed only when the tab 

is displayed or when Refresh is clicked. 

Network 

Status 

(Under CAN control only.) Status of CANopen network. Lists warnings and 

errors. 

 
Saves the contents of the History and Frequency tabs to a text file. 

 Clears all History and Frequency entries in the drive. 

 
Updates the contents of the History or Frequency tabs. 
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This section describes how to use the Error log window to view warnings and faults recorded 

to the Flash memory in the drive. 

1. Select the error log icon on the CME menu: 

 

2. Once the Error Log window opens, select the icon on the bottom left corner “Save the 

error log to disk”  

 

3. Save the error log using a descriptive name such as olderrorlog.txt. Once the error log is 

saved on the Logfiles folder, select the History tab (1) on the Error log screen and click 

Clear Log (2). 
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4. After you clear the log, it should look like the picture below.  

 

5. Make sure there are no active faults when clicking on the Active Tab (first tab next to 

History). Then, power cycle the drive. 

6. Once the drive comes back, please check the Active Tab again to see if the issue returns. 

If the issue is back, then save the error log using a descriptive name such as 

newerrorlog.txt.  

In case the issue persists, you can request technical assistance. Please send us the new and 

old .ccx file as well as the error log. You may ask for help here: 

www.copleycontrols.com/en/contact-us 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.copleycontrols.com/en/contact-us


 

 

8 Copley Controls                   16-130742rev01 

 

Loading a Configuration File 

In some cases, it will be necessary for you to load a “well known” configuration file. This file 

could be in a variety of formats; please see below: 

1. Go to File → Restore and select the appropriate file format. 

 

2. Navigate to the location of the config file on your computer. 

 

Downloading Firmware 

In some cases, you will need to load new firmware into the drive. CME makes this process 

effortless and simple.  

1. On the CME menu select Tools →Download Firmware. 
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2. Navigate to the location of the firmware file in your computer. 

WARNING: Do not power down or disconnect the amplifier during firmware download. 

 

When the progress dialog closes, the firmware download is complete. 

 

Boot Mode  
Boot mode state is safe state which is usually triggered by an interruption on the 
communication with the drive while downloading firmware. See below on the procedures for 

getting the drive out of Boot Mode. 
 

To get the drive out of Boot Mode, please use the following steps. 

 
1. Connect the Copley USB to Serial adapter (Part# SER-USB-RJ11) to serial port on the 

drive. 
 

2. Connect basic power to the drive (+24v) 
 

3. Open CME and select one of the communication ports under Copley Neighborhood, you 
should see the message below: 

 

 

 
 

4. Select Yes and download the appropriate firmware, wait for the process to be done. 
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Faults and Warnings 

The images below depict the way faults and warnings are displayed in CME. Faults will be 

displayed with a red background, while warnings will be displayed with a yellow background.  

 

Please refer to list below to identify Status, Warnings and Faults and their recommended 

corrective action.  

Bit Event Name  Description Corrective Action 

0 Fault Short Circuit Output to motor or regen 
measured is greater than 

twice peak 

Check cable and motor or 
regen for short output to 

ground or output to output. 

1 Fault Drive over 

temp 

Amp over temp drive 

protection. 

Increase air flow, add 
heatsink kit, or reduce duty 

cycle. 

2 Fault Over voltage DC bus above drive 

rating. Output shutdown 

Check DC bus for pump up 
when stopping, add 

capacitance, or reduce 

deceleration rate. 

3 Fault Under voltage DC bus below minimum Check DC bus for drooping 

or collapsing, improve 
power source, or reduce 

acceleration. 

4 Fault Motor temp 

sensor  

 

Motor temperature sensor 

open or closed  

 

Check motor temperature 

confirm sensor circuit. 

5 Fault Feedback 

error  

 

Problem with feedback 

circuits 

Check Encoder Status for 
more details, check voltage 

levels, Confirm Encoder 

power regulated. 

6 Fault Phasing error Problem with 

commutation or phasing 

Check Halls states vs 

Encoder count. Test 
encoder for no drift. Do not 

hot swap. Check manual 

phasing. 

7 Warning Current Current folds back to Reduce duty cycle, remove 
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Bit Event Name  Description Corrective Action 

limited protect the drive or motor friction, Check motor Arms 

vs drive Ic Apk ratings. 

(1Arms = 1.414Apk). 

8 Warning Voltage 

limited 

PWM output hits 95% 

duty cycle 

Momentary voltage limit is 

okay however, if output 
speed is limited and waning 

is constant then increase dc 

bus or slow down. 

9 Fault Pos limit 

switch 

Positive limit switch is 

active move aborts 

If hold position at limit is 

selected, then motor will 
servo in position otherwise 

no current in direction of 

limit 

10 Fault Neg limit 

switch 

Negative limit switch is 

active move aborts 

If hold position at limit is 

selected, then motor will 
servo in position otherwise 

no current in direction of 

limit 

11 Status HW Enable 

inactive 
Hardware Enable Check IN1 for correct 

levels. Typically, IN1 input 

(SW input 0) is active low 
enable and stop settings 

are configured for 

controlled stop. 

12 Status SW Enable 

inactive 
Software Enable Check that master can 

move drive to op-state. If 
Copley mode is "Disabled" 

change to another mode. 

13 Warning Stopping Trajectory aborted 

attempting to stop 

Normal event when 
hardware disabled or 

master commands. 
Trajectory will abort when 

fault occurs so check faults 

for root cause. 

14 Status Brake 

activated 
Brake FET is turned on Check that brake is holding 

15 Fault PWM disabled Drive PWM output H-

bridge stage is OFF 

Check for HW and SW 

enable or no faults 

16 Status Pos soft limit Positive Software limit Soft limits apply after 
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Bit Event Name  Description Corrective Action 

homing. Move will stop 

using soft limit deceleration 
rate and hold on soft limit. 

Check soft limit 

deceleration rate. 

17 Status Neg soft limit Negative Software limit Soft limits apply after 

homing. Move will stop 
using soft limit deceleration 

rate and hold on soft limit. 
Check soft limit 

deceleration rate. 

18 Fault Tracking error Following error limit 

exceeded 

Some limit is preventing 
move. Check mechanical 

system and current limits. 

Reduce duty cycle. 

19 Warning  Tracking 

warning 

Following error above 

warning limit 

Danger of following error. 

Some limit is affecting 

move. Check mechanical 
system and current limits. 

Reduce duty cycle. 

20 Status Resetting Drive is presently being 

reset 

Wait for reset to complete 

21 Status Position wrap Position has wrapped If wrap is set to some value 

count will start at 0 again 
at that value. Otherwise, if 

wrap is not set, the Position 
variable wraps at full scale 

range. This type of counting 
is called position wrapping 

or modulo count. 

22 Fault Drive Fault Power-up diagnostic Rest or power cycle the 
drive. Make sure power 

cabling and grounding is 

correct. 

23 Warning Velocity limit velocity limited to 

configured value 

Increase the velocity limit 

to 10% greater than rated 

or required speed 

24 Warning Acceleration 

limit 

Acceleration limits 

command 

Velocity mode only. If 

command exceeds limit the 
summing junction will only 
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Bit Event Name  Description Corrective Action 

get limit. 

25 Warning Tracking 

Window 

Following error is in 

tracking window 

If Position Loop Error is 

outside of Position Tracking 
Error Limit, then position is 

not tracking, or move has 

not settled. 

26 Status Home switch 

active 
Home switch input active An input configured as 

home switch will capture 
position when activated. 

Normally for purposes of 

homing. 

27 Status In motion Moving or not settled Set if the trajectory 

generator is running a 
profile, or the Position 

Tracking Error Limit is 
outside the tracking 

window. Clear when settled 

into position. 

28 Status Velocity 

window 
Velocity not tracking Set if the absolute velocity 

error exceeds the velocity 

window value. 

29 Warning Phase not 

initialized 

Algorithmic (No Halls) 

commutation run after 

enable 

After enable algorithmic 

phasing will wiggle the 

motor to find phase. 
Confirm phase initialized 

and good before 

commanding move. 

30 Fault Command 

Input 

Master command signal 

not present. 

Master (CANopen or ECAT) 

not connected or not 
sending message in time 

configured by master. Turn 
off guard time if CANopen 

master not connected. If 
PWM command source 

check for command or allow 

100% command. 

31 Fault Not defined    
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Revision History 

Date Version Revision 

1/22/2021 Rev 00 Initial release 

6/25/2021 Rev 01 Added Boot Mode section 

   

 


